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Workflow IR 8 - Plan & Profile Generator

This document guides you through using the Plan and Profile Generator command in InRoads. The InRoads 
Plan and Profile Generator can be used for:

 Creating Roadway plan sheets depicting both plan and profile views on a single sheet.

 Full plan view sheets and double plan sheets (suitable for Roadway or Right-of-way plans).

 Full profile view sheets and double Profile Sheets.

Workflow Outline

Check Out Sheet Files - Checking out the sheet files in advance allows Plan and Profile Generator to be run 
multiple times.

♦ Command Used: Check Out - This allows the user to edit (rerun P&P Generator) as needed.

Open Profile DGN File and Plan and Profile Generator - When the Plan and Profile Generator 
command is executed, it creates the profiles for the sheets first. Therefore, the dgn file that will contain the 
profiles must be opened at the time the command is launched.

♦ Command Used: MicroStation File > Open - Used to open a dgn file for editing. 

♦ Drafting > Plan and Profile Generator - This opens the dialog box use to generate plan sheets.

User Input - This command requires a number of user inputs to obtain the desired results. These inputs are 
entered on various tabs within the Plan and Profile Generator dialog box. The inputs 

♦ Global Scale Factor - Used to set the InRoads text size. Set this before the command is executed.

○ Command Used: Tools > Global Scale Factor - Used to set the size factor for text and cells.

♦ Main Tab - This tab is used to set the Preference, alignment used, station extents, etc.

○ Preferences - Used to set the basic settings for most of the tabs. This should be selected before 
any other settings are made.

○ Horizontal Alignment - Used to define which alignment the plan and profile sheets will follow.

○ Station Limits - Used to define where along the horizontal alignment the sheets are made and how 
long each sheet will be.

♦ Plan Controls Tab - Used to specify the Reference Files used for the plan part of the sheet.

○ Model Files button - Used to select reference files for the plan section of the sheets.

♦ Profile Controls Tab - Used to set the profile preference, size, and data used.

○ Profile Preference - This determines some of the basic profile settings, like vertical 
exaggeration.

○ Vertical Alignment - Used to adjust the profile settings to accommodate the data.

○ Corridor - Used to specify which corridor will be used for superelevation data.

○ Surface - Used to specify which surfaces are displayed and which surface controls profile shifts.

○ Profile Elevation Shifts - Used to specify where profile shifts occur.

♦ Sheet Layout Tab - Used to specify the name for the plan sheets and identify the seed file used to 
create them.

○ Host File - Used to specify the name for the plan sheets.

○ Seed Host File - Used to specify the seed file used to create the plan sheets.
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♦ Border and Title Tab - Used to specify the sheet border cell to be used for the plan sheets.

○ Cell > Name - Used to specify the sheet border cell to be used for the plan sheets.

♦ Symbols and Details Tab - Used to specify two cells to be placed on each sheet.

○ North Arrow > Cell Name - Used to specify the north arrow cell to be used on the plan sheets.

○ Miscellaneous > Cell Name - Used to specify any other cell to be used on every plan sheet.

Editing Sheet Definitions - InRoads does not always create the sheets as the user desires. The following tabs 
are used to adjust the sheets.

♦ Main Tab - This tab is used to adjust sheet extents and add additional reference files to sheets.

○ Plan Views > Use Plan Views - This toggle tells InRoads to use the defined plan view settings 
instead of recreating these settings based on the station limits.

○ Plan View List - Used to select individual plan view definitions for editing.

♦ Sheet InDex Tab - Used to navigate between plan sheets and to adjust the location of reference files.

○ Sheet Index List - Used to select a plan sheet for display or editing.

○ Show Sheet Button - Used to open the selected sheet in MicroStation.

○ Regenerate Sheet Button - Used to recreate the selected sheet with data modified on the Main 
tab and the Sheet Index tab.

○ Delete Sheet Button - Used to remove a sheet from the plan list.

○ Sheet Views List - Use to select and edit the location of the Plan and Profile reference fiels.

Required Resources:

Before you begin, a number of resources are required for this command. 

Horizontal Alignment ‐ Plan view limits are defined relative to a horizontal alignment (length and right/left 
offsets). Therefore, a project specific Geometry Project must be loaded into memory.

Digital Terrain Models - Profile view limits are determined by the vertical relief of profiled DTM’s. At least 
one project specific DTM must be loaded into memory.

Cells - Cells are used to place the Drawings border and north arrows. The cell library 
General.cel must be attached for the Plan and Profile Generator to operate correctly.

Border Sheet - A Cell is used to generate the border sheet and is placed in each drawing created.

Source cell library: 

C:\Program Files\Workspace‐CDOT\Standards‐Global\MicroStation\cells\General.cel 

Cell Placed: SHEET_Design‐Sheet

Scale - Before the P&P command is run, the user needs to determine the final plot scale of the drawings being 
created. Current preferences exist for 20, 40, 50, 100, 200, and 500 scale plots. This is reflected on specific tabs 
within the command. See below for additional information.
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JPC#DES_PnP##.dgns ‐ In ProjectWise, if the PnP sheet files are not checked out in advance of running Plan 
and Profile Generator, then Plan and Profile Generator can only be run once. It will not overwrite the sheets 
created. Checking the sheets out in advance allows the program to overwrite the sheets each time the command 
is executed. Fifteen JPC#DES_PnP##.dgn files are included in the Drawings folder when a new project is 
created. If additional sheets are required, copy one of the provided sheets and rename the copy to be in 
sequence with the others.

Under Tools > Options > Factors the Global Scale Factor must be set to match the Plan & Profile Generator 
preference (horizontal scale) selected.

Starting InRoads

1. From the ProjectWise Explorer, check out the desired number of  JPC#DES_PnP##.dgn files. In this 
example the files 12345DES_PnP01.dgn through 12345DES_PnP10.dgn were selected.

2. Open the \JPC#\Design\Drawings\Reference Files\12345DES_Prof.dgn file from the ProjectWise 
Explorer.

3. Load the desired InRoads data.

Dialog Settings:

Project specific parameters need to be defined prior to command execution:

♦ Verification of Border Cell

♦ Location of MicroStation seed file

♦ Location for sheet output (project directory)
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♦ Length along the alignment that will display in plan view

♦ Left and right offsets from a horizontal alignment for plan view display.

User Input:

1. Select Drafting > Plan and Profile Generator…

By default, the dialog will populate with the CDOT preference (100 horizontal scale by 1x vertical 
exaggeration Plan & Profile sheet).

2. <D> Preferences if a different scale or full plan sheet or double plan sheet or full profile sheet is desired:

Developed Preferences are:

♦ 100 Scale Double Plan – 100 scale (plot factor) double plan sheet

♦ 100 Scale Full Plan Sheet – 100 scale (plot factor) plan sheet

♦ 100 Scale Full Profile 10x – 100 scale (plot factor) full sheet profile with 10 times vertical exaggeration 
applied

♦ 100 Scale Double Profile 10x – 100 scale (plot factor) double profile sheet with 10 times vertical 
exaggeration applied

♦ 100 Scale Full Profile 1x - 100 scale (plot factor) full sheet profile with 1 times vertical exaggeration 
applied

♦ 100 Scale Full Profile 2x - 100 scale (plot factor) full sheet profile with 2 times vertical exaggeration 
applied

♦ 100 Scale P&P (1x Vert) - 100 scale (plot factor) plan & profile with 1 times vertical exaggeration 
applied

♦ 100 Scale P&P (2x Vert) - 100 scale (plot factor) plan & profile with 2 times vertical exaggeration 
applied

♦ 100 Scale P&P (5x Vert) - 100 scale (plot factor) plan & profile with 5 times vertical exaggeration 
applied

♦ 100 Scale ROW Plan Sheet

♦ Replicas of the above for 20, 40, 50, 200, and 500 scale as appropriate

Note: There is a second copy of the preferences that are prefixed with a ‘PW’. These use a ProjectWise sheet 
border. Once the file is saved then reopened, ProjectWise will fill in the title block information 
automatically.
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Main Tab

By default, the preference CDOT 100 Scale P&P (1xVert) will load & populate the dialog for generation of plan 
and profile sheets.

User input – Main Tab

Load the appropriate Preference (if necessary)

1. Select the Horizontal Alignment to be centered in the plan view

2. Define Start and Stop stations to define limits of sheet generation

3. Length defines the length along the alignment that will fit in a plan view. 1400 feet is the default for a 100 
scale 11” x 17” plotted sheet. See graphic below.

Changing Scale

A 50 scale plot will display 700 feet along the alignment in plan view, a 200 scale plot will display 2800 feet.
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If something other than 100 scale is desired, the different scaled preferences are created to proportionally 
change the following:

♦ Main tab – modifies Length along Alignment

♦ Plan Controls tab – modifies Width Left and Width Right of reference line (alignment)

♦ Profile Controls tab – modifies Profile Height

♦ View Layout tab – modifies Scale

♦ Symbols and Details tab – modifies Scale

♦ One item that is not set by the preferences and that needs to be set by the user is the overall InRoads 
scale which is set by selecting the command:
Tools> Options> Factors or Tools > Global Scale Factor – set Text, Cell, LineStyle to the 
desired plot scale

Plan Controls Tab

1. <D> Model Files to pick the Drawing files (references) for display in plan view. These files can be 
located on ProjectWise or on the local hard drive.

Note: Nested Attachments can be checked, but you will only be able to manipulate levels (on or off) 
through Level Display and not in the Level Manager. Also, you can switch to live nesting in the 
actual P&P sheets by changing the reference file attachment settings.   
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2. The inputs Width Left and Width Right define plan view limits perpendicular from the reference line (left 
is negative).

3. The Boundary Chords setting will create a clipping limit that will fit the extents of the upper plan window 
area. This reference file clipping edge should be considered a “first pass limit” and may have to be edited 
on curved portions of the corridor path in locations where the cut / fill limits extend outside this 
“calculated” clipping limit. This plan limit editing, along with any shifting of the plan window position, is 
accomplished on the Sheet Index tab after the sheets have been created.

Model Files & Levels

The Model files selected (along with the profile generated) will be attached as reference files. The attached 
files will have the levels turned on that contain data. If additional data (levels) are added to the referenced files 
after the sheets are created, the user is required to turn on the appropriate levels through the use of the level 
display dialog box.

Additionally, the files referenced will have the design file ‘CDOT Default’ model attached. It is CDOT policy 
that only the model titled ‘CDOT Default’ should be used in any MicroStation file.

Profile Controls Tab

1. Profile Preference defines profile grid settings (ticks, annotation, grid/tick spacing etc.) as stored as a pref-
erence in Evaluation > Profile >Generate Profile.

2. Enter an appropriate profile Set Name. For better tracking and locating, this field will default to the name 
of the Horizontal Alignment from the Main tab.
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3. Select the Vertical Alignment from the drop-down list. (This tells InRoads to create a profile window with 
an elevation range compatible with the vertical design.) The alignment specified determines window 
clearance (top/bottom profile grid clearance) and vertical profile shifts if necessary.

4. Check on (X) any Surface that you wish to display in the profile window as it is created (you can always 
display additional data after the profiles have been constructed). 

5. Hold down the CTRL key and select any Surface that should be considered when establishing the elevation 
range position of the profile window. These selected surfaces can also affect the Profile Elevation Shifts 
locations.

6. Highlight the superelevation control lines that will be displayed in the profile from the Super Control Lines 
list box. The All and None buttons to the right of the Super Control Lines list box can be used to select or 
deselect all of the superelevation control lines.

Note: The Margin on the Top has additional space provided in case a superelevation diagram is shown in 
combination with the profile window.

From the InRoads help menu:

When a profile is shifted (vertically), the starting elevation will always be a multiple of the 
Spacing value for the ticks on the left axis in the Create Profile command. To set this parameter, go 
to the Axes tab on the Create Profile dialog box, set Axis to Left, set Annotation to Ticks, and key 
in the Spacing value in the Major Ticks group box. Therefore, if you get a message stating that the 
profile will not fit in the given profile height, you have two choices: (1) increase the profile height 
or (2) specify a smaller spacing value for the left axis.
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Sheet Layout Tab

1. <D> … next to the Host File field to identify the path and initial sheet name for the new drawing set. The 
Host File refers to the new MicroStation plan and profile drawings that will be created by this tool. The last 
number, “1”, will be automatically updated as each new sheet is created. This should be set to the project 
directory, i.e.: C:\Projects\12345\ Design\Drawings\12345DES_PnP01.dgn.

Note: This can also be a path to a ProjectWise location.

2. The Seed Host File is the ‘prototype’ file used to create the Host files. Verify the path is set 
to:C:\Workspace\Workspace-CDOT_V8i\Standards-Global\MicroStation\seed\3D-
Seed_CDOT.dgn

3. The Symbology for the Clipping Boundary will be blank since the Level specified will determine the 
clipping boundary symbology.
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View Layout Tab

1. This tab sets location (origin) for the profile and plan views relative to the border sheet. No user input is 
required in this dialog unless creating sheets at a scale other than 1”=100’

Note: The Location of the Profile Y position was determined by 1.50” of outside title block border plus 
0.25” of clear space for the station text at that bottom of the profile window. (1.50+0.25 = 1.75)

Note: The Location of the Plan Y position was determined by 1.50” of outside title block border plus 
0.25” clear space for the station text below the profile window plus 4.5” of space required for 45’ 
of profile elevation plus 0.25” of clear space above the profile window plus ½ of the remaining 4” 
width of the plan window. (1.50+0.25+4.50+0.25+2.00 = 8.50)

Border and Title Tab

The only user input on this tab is to ensure the correct cell is specified for the border sheet and turn off the User 
Text if it is not used. 



Colorado Department of Transportation   PPG- 11

CDOT  Workflows  Plan & Profile Generator

1. Cell Placed: 

♦ SHEET_PW_Design-Plan-Sheet
♦ SHEET_Design-Sheet

Note: Use the SHEET_PW_Design-Plan-Sheet with projects located on ProjectWise. Use 
SHEET_Design-Sheet with projects stored on a local computer.

Symbols and Details Tab

The North Arrow cell is preset on this tab. The ProjectWise Title Block area is not used because the 
ProjectWise tags are imbedded in the sheet border cell. The Miscellaneous area can be used to place another 
cell in the sheet. To use the Miscellaneous area:

1. Toggle on Attach.

2. Select the desired Cell Name.

3. Toggle on Retain Cell Levels for Each Sheet.

4. Key in the desired Scale.
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5. Key in the X and Y values for the Location in Paper Units.

Note: The North Arrow position is specified by the Location in Paper Units input and is set to the upper 
right corner of the sheet. This is a rough placement and will likely have to be moved for clarity and 
conflicts on many sheets. Once the sheets are constructed each sheet should be checked for 
optimum cell position. 

Note: The North Arrow and matchline information are not being placed on the correct level. A 
workflow document has been created to assist you in moving the North Arrow and matchline 
information to the correct level through a batch process. If these elements are not moved to the 
correct level, they will not plot. InRoads places these elements on a no plot level. See the CDOT 
Batch Processing workflow document for more information on this process. 
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Match Lines Tab

1. No user input is required in this dialog.

Executing the Command

The workflow process for this command follows the sequence:

1. New profiles are generated for referencing to individual sheets.

2. Plan view reference limits are established.

3. New drawing files are created based on the host file name.

4. Each new drawing file has 3 items generated (Sheet Border, North Arrow, and one user specified cell).

5. Plan views or Plan and Profile views.

6. Profile views.

7. Border sheet placed as a cell in each generated drawing.

8. North arrows are placed in all sheets.

9. The Plan and Profile dialog (sheet index tab) will populate with sheets created and sheet limits.
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Note: Because new profiles will be generated, you should execute the command in a drawing specific for 
this use. For example:  
C:\Projects\12345\Design\Drawings\Reference_Files\12345DES_Prof.dgn 

Sheet Index Tab

1. Nothing is required by the user on this tab prior to Plan & Profile sheet creation.

2. After the Plan and Profile Generator has been run, each sheet should be reviewed for:

♦ North Arrow position and Miscellaneous Cell. (Manually move the Cell if necessary).

♦ Plan view Clipping limits (Using MicroStation Modify, edit the clipping shape). This level is set to be 
on a no plot level.

♦ Plan View Position (Select the sheet on the Sheet Index tab, modify the anchors as necessary, and 
Regenerate Sheet to reconstruct).

3. Save a project specific View Definition File (VDF) so that sheet definitions can be recalled and modified if 
necessary. This file should be saved to your InRoads project folder location, not within the CDOT 
Workspace. 
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4. By highlighting a specific sheet and <D> Show Sheet, MicroStation will open the selected drawing.

Main Tab

1. Once the command has been run the Geometry Projects in this VDF, Plan View and Profile View list boxes 
are updated.
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2. <D> <D> on a Plan or Profile View in the list to open an Edit dialog box. Sheet limits can be modified and 
reference files can be added or removed from this location. 

Note: If you are using ProjectWise and you are going to regenerate the P and P sheets, you must first delete 
the sheets off of the ProjectWise server. InRoads cannot overwrite files on the ProjectWise server as it 
does with locally stored files.
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